summary refs log tree commit diff stats
path: root/plugins/lua/meson.build
diff options
context:
space:
mode:
authorPatrick Griffis <tingping@tingping.se>2016-12-13 16:12:03 -0500
committerPatrick Griffis <tingping@tingping.se>2017-06-13 23:54:51 -0400
commit628100c19f5d82747170acdf2917cba8c119ccbf (patch)
tree351a7e9714a1a58390ba349808df5703cef25c3e /plugins/lua/meson.build
parent2edf50d4ddc61ce6f73bf02263c9bdd09632c66b (diff)
build: Replace Autotools with Meson
Quick rundown of benefits:

- Much faster:
  - Autotools (with autogen): 22 seconds
  - Meson: 7 seconds
  - Meson (with ccache): 2 seconds

- Simpler:
  - ~1000 lines smaller
  - Single simple language

- Potentially better Windows (Visual Studio) support

What is not done:

- Complete Windows support
- OSX support (easy)

Closes #2013
Closes #1937
Closes #1803
Diffstat (limited to 'plugins/lua/meson.build')
-rw-r--r--plugins/lua/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/plugins/lua/meson.build b/plugins/lua/meson.build
new file mode 100644
index 00000000..7faa3054
--- /dev/null
+++ b/plugins/lua/meson.build
@@ -0,0 +1,12 @@
+if cc.get_id() == 'msvc'
+  lua_dep = cc.find_library('lua51')
+else
+  lua_dep = dependency(get_option('with-lua'))
+endif
+
+shared_module('lua', 'lua.c',
+  dependencies: [libgio_dep, hexchat_plugin_dep, lua_dep],
+  install: true,
+  install_dir: plugindir,
+  name_prefix: '',
+)