summary refs log tree commit diff stats
path: root/plugins/lua/Makefile.am
diff options
context:
space:
mode:
authorPatrick Griffis <tingping@tingping.se>2016-04-03 10:28:11 -0400
committerPatrick Griffis <tingping@tingping.se>2016-04-03 10:30:01 -0400
commit2e478f1b5a8ffbc388652a28d17f374fc7a82145 (patch)
treefd05cbd2917232c781500aab4a2e7c2014a93e27 /plugins/lua/Makefile.am
parenta77c6df7e271dfaee8b27d73da380d1759593e07 (diff)
Import lua plugin
Written by @mniip
Diffstat (limited to 'plugins/lua/Makefile.am')
-rw-r--r--plugins/lua/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/plugins/lua/Makefile.am b/plugins/lua/Makefile.am
new file mode 100644
index 00000000..b98d5f66
--- /dev/null
+++ b/plugins/lua/Makefile.am
@@ -0,0 +1,9 @@
+libdir = $(hexchatlibdir)
+
+lib_LTLIBRARIES = lua.la
+lua_la_SOURCES = lua.c
+lua_la_LDFLAGS = $(PLUGIN_LDFLAGS) -module
+lua_la_LIBADD = $(LUA_LIBS) $(GLIB_LIBS)
+lua_la_CPPFLAGS = -I$(top_srcdir)/src/common
+lua_la_CFLAGS = $(GLIB_CFLAGS) $(LUA_CFLAGS)
+