summary refs log tree commit diff stats
path: root/plugins/fishlim/tests/meson.build
diff options
context:
space:
mode:
authorPatrick Griffis <tingping@tingping.se>2021-11-03 09:59:24 -0500
committerPatrick Griffis <tingping@tingping.se>2021-11-03 09:59:24 -0500
commit4f3ef3505a5f34c85e0935dc1ca4d14f27590ae5 (patch)
treedfb6229091899ae1f0d4a250d5be4c379d4724f3 /plugins/fishlim/tests/meson.build
parentb54593e7527566e1bb46e404ea8a91ee4e493f57 (diff)
fishlim: Minor test improvements
- Don't have tests repeat themselves, meson has a `--repeat` flag
- Fix a minor leak of a GRand
- Speed up a test
- Increase timeout

This still needs a lot of improvements, it runs at lot of loops within
loops generating random strings that could be optimized. This means
it can take a very long time on some computers.

Closes #2629
Diffstat (limited to 'plugins/fishlim/tests/meson.build')
-rw-r--r--plugins/fishlim/tests/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/plugins/fishlim/tests/meson.build b/plugins/fishlim/tests/meson.build
index 60eddc18..1a0394a3 100644
--- a/plugins/fishlim/tests/meson.build
+++ b/plugins/fishlim/tests/meson.build
@@ -12,4 +12,5 @@ fishlim_tests = executable('fishlim_tests', fishlim_test_sources,
 
 test('Fishlim Tests', fishlim_tests,
   protocol: 'tap',
+  timeout: 600,
 )