summary refs log tree commit diff stats
path: root/plugins/fishlim/Makefile.am
diff options
context:
space:
mode:
authorRainer Müller <raimue@codingfarm.de>2016-09-27 00:29:33 +0200
committerPatrick Griffis <tingping@tingping.se>2016-09-26 19:16:42 -0400
commitc79ce843f495b913ddafa383e6cf818ac99b4f15 (patch)
tree918226f0eb20b148d8a8140a9463d2f59fdf0e5f /plugins/fishlim/Makefile.am
parent49758cafba9fd7e0663b550debfd51fb21260650 (diff)
build: Reorder includes to avoid installed plugin header
When hexchat is already installed into a non-default prefix, a new build
could pick up ${prefix}/include/hexchat-plugin.h from the installed
version instead of the local header, as configuration variables such as
$(GLIB_CFLAGS) would point to -I${prefix}/include.

Reordering the includes and moving -I arguments to CPPFLAGS prevents
this, as it ensures the local directories are always searched first.

This was no problem when compiling for /usr or /usr/local as these
directories in the compiler search path are always searched last.

Closes #1822
Diffstat (limited to 'plugins/fishlim/Makefile.am')
-rw-r--r--plugins/fishlim/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/plugins/fishlim/Makefile.am b/plugins/fishlim/Makefile.am
index d8193a6e..95498bf5 100644
--- a/plugins/fishlim/Makefile.am
+++ b/plugins/fishlim/Makefile.am
@@ -6,4 +6,5 @@ lib_LTLIBRARIES = fishlim.la
 fishlim_la_SOURCES = fish.c irc.c keystore.c plugin_hexchat.c
 fishlim_la_LDFLAGS = $(PLUGIN_LDFLAGS) -module
 fishlim_la_LIBADD = $(GLIB_LIBS) $(OPENSSL_LIBS)
-fishlim_la_CFLAGS = $(GLIB_CFLAGS) $(OPENSSL_CFLAGS) -I$(top_srcdir)/src/common
+fishlim_la_CPPFLAGS = -I$(top_srcdir)/src/common
+fishlim_la_CFLAGS = $(GLIB_CFLAGS) $(OPENSSL_CFLAGS)