summary refs log tree commit diff stats
path: root/meson.build
diff options
context:
space:
mode:
authorPatrick Griffis <tingping@tingping.se>2017-06-15 00:26:43 -0400
committerPatrick Griffis <tingping@tingping.se>2017-06-15 00:26:43 -0400
commitce91bebc39a649511bf85ee75b5323bbdfa55655 (patch)
tree9ffc428756b4e474603fb9b7e813de8ec3864f6d /meson.build
parent27fd9b3fd6972cc8b3de524bd5f88628fdc4250c (diff)
Fix OpenSSL 1.1 deprecations
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 462673fb..15eaa390 100644
--- a/meson.build
+++ b/meson.build
@@ -64,6 +64,12 @@ if libssl_dep.found()
   config_h.set('HAVE_DH_SET0_KEY',
     cc.has_function('DH_set0_key', dependencies: libssl_dep)
   )
+  config_h.set('HAVE_ERR_REMOVE_THREAD_STATE',
+    cc.has_function('ERR_remove_thread_state', dependencies: libssl_dep)
+  )
+  config_h.set('HAVE_ASN1_STRING_GET0_DATA',
+    cc.has_function('ASN1_STRING_get0_data', dependencies: libssl_dep)
+  )
 endif
 
 configure_file(output: 'config.h', configuration: config_h)