summary refs log tree commit diff stats
path: root/data/misc/meson.build
diff options
context:
space:
mode:
authorPatrick Griffis <tingping@tingping.se>2017-12-24 12:09:36 -0500
committerPatrick Griffis <tingping@tingping.se>2017-12-24 13:00:40 -0500
commit7d7be8321613acf4a613894163b8468f107415de (patch)
tree07e9fcd19c33e7f0fe506c4c8026bedcf54ea4ae /data/misc/meson.build
parent005858795878b92fc17b4c2127bce90a1d053483 (diff)
Rename app-id to io.github.Hexchat
RDNS syntax is recommended for applications and this matches the
existing flatpak. Note that the dbus service and icons still need
renaming though the former is an API breakage.

Closes #2104
Closes #2103
Diffstat (limited to 'data/misc/meson.build')
-rw-r--r--data/misc/meson.build22
1 files changed, 11 insertions, 11 deletions
diff --git a/data/misc/meson.build b/data/misc/meson.build
index b5532d63..9ece6192 100644
--- a/data/misc/meson.build
+++ b/data/misc/meson.build
@@ -3,8 +3,8 @@ desktop_utils = find_program('desktop-file-validate', required: false)
 
 if get_option('with-gtk')
   hexchat_appdata = i18n.merge_file(
-    input: 'hexchat.appdata.xml.in',
-    output: 'hexchat.appdata.xml',
+    input: 'io.github.Hexchat.appdata.xml.in',
+    output: 'io.github.Hexchat.appdata.xml',
     po_dir: '../../po',
     install: true,
     install_dir: join_paths(get_option('datadir'), 'appdata')
@@ -12,7 +12,7 @@ if get_option('with-gtk')
 
   appstream_util = find_program('appstream-util', required: false)
   if appstream_util.found()
-    test('Validate hexchat.appdata.xml', appstream_util,
+    test('Validate io.github.Hexchat.appdata.xml', appstream_util,
       args: ['validate', hexchat_appdata]
     )
   endif
@@ -25,14 +25,14 @@ if get_option('with-gtk')
   endif
 
   desktop_file = configure_file(
-    input: 'hexchat.desktop.in.in',
-    output: 'hexchat.desktop.in',
+    input: 'io.github.Hexchat.desktop.in.in',
+    output: 'io.github.Hexchat.desktop.in',
     configuration: desktop_conf
   )
 
   hexchat_desktop = i18n.merge_file(
     input: desktop_file,
-    output: 'hexchat.desktop',
+    output: 'io.github.Hexchat.desktop',
     po_dir: '../../po',
     type: 'desktop',
     install: true,
@@ -40,7 +40,7 @@ if get_option('with-gtk')
   )
 
   if desktop_utils.found()
-    test('Validate hexchat.desktop', desktop_utils,
+    test('Validate io.github.Hexchat.desktop', desktop_utils,
       args: [hexchat_desktop]
     )
   endif
@@ -48,8 +48,8 @@ endif
 
 if get_option('with-theme-manager')
   htm_desktop = i18n.merge_file(
-    input: 'htm.desktop.in',
-    output: 'htm.desktop',
+    input: 'io.github.Hexchat.ThemeManager.desktop.in',
+    output: 'io.github.Hexchat.ThemeManager.desktop',
     po_dir: '../../po',
     type: 'desktop',
     install: true,
@@ -57,12 +57,12 @@ if get_option('with-theme-manager')
   )
 
   if desktop_utils.found()
-    test('Validate htm.desktop', desktop_utils,
+    test('Validate io.github.Hexchat.ThemeManager.desktop', desktop_utils,
       args: [htm_desktop]
     )
   endif
 
-  install_data('htm-mime.xml',
+  install_data('io.github.Hexchat.ThemeManager.xml',
     install_dir: join_paths(get_option('datadir'), 'mime/packages')
   )
 endif