summary refs log tree commit diff stats
path: root/data/misc/Makefile.am
diff options
context:
space:
mode:
authorPatrick Griffis <tingping@tingping.se>2016-12-13 16:12:03 -0500
committerPatrick Griffis <tingping@tingping.se>2017-06-13 23:54:51 -0400
commit628100c19f5d82747170acdf2917cba8c119ccbf (patch)
tree351a7e9714a1a58390ba349808df5703cef25c3e /data/misc/Makefile.am
parent2edf50d4ddc61ce6f73bf02263c9bdd09632c66b (diff)
build: Replace Autotools with Meson
Quick rundown of benefits:

- Much faster:
  - Autotools (with autogen): 22 seconds
  - Meson: 7 seconds
  - Meson (with ccache): 2 seconds

- Simpler:
  - ~1000 lines smaller
  - Single simple language

- Potentially better Windows (Visual Studio) support

What is not done:

- Complete Windows support
- OSX support (easy)

Closes #2013
Closes #1937
Closes #1803
Diffstat (limited to 'data/misc/Makefile.am')
-rw-r--r--data/misc/Makefile.am50
1 files changed, 0 insertions, 50 deletions
diff --git a/data/misc/Makefile.am b/data/misc/Makefile.am
deleted file mode 100644
index 45036a3c..00000000
--- a/data/misc/Makefile.am
+++ /dev/null
@@ -1,50 +0,0 @@
-
-appdatadir = $(datadir)/appdata
-appdata_in_files =
-
-if DO_GTK
-appdata_in_files += hexchat.appdata.xml.in
-endif
-
-appdata_DATA = $(appdata_in_files:.xml.in=.xml)
-@INTLTOOL_XML_RULE@
-
-if USE_DBUS
-exec_command = 'hexchat --existing %U'
-else
-exec_command = 'hexchat %U'
-endif
-
-hexchat.desktop.in: hexchat.desktop.in.in
-	$(AM_V_GEN)sed -e s!\@exec_command\@!$(exec_command)! < $< > $@
-
-data_desktopdir = $(datadir)/applications
-data_desktop_in_files =
-
-if DO_GTK
-data_desktop_in_files += hexchat.desktop.in
-endif
-
-if WITH_TM
-data_desktop_in_files += htm.desktop.in
-mime_DATA = htm-mime.xml
-mimedir = $(datadir)/mime/packages
-endif
-
-data_desktop_DATA = $(data_desktop_in_files:.desktop.in=.desktop)
-@INTLTOOL_DESKTOP_RULE@
-
-UPDATE_MIME_DATABASE = update-mime-database "$(datadir)/mime" || :
-UPDATE_DESKTOP_DATABASE = update-desktop-database -q "$(datadir)/applications" || :
-
-install-data-hook:
-	$(UPDATE_MIME_DATABASE);
-	$(UPDATE_DESKTOP_DATABASE);
-
-uninstall-hook:
-	$(UPDATE_MIME_DATABASE);
-	$(UPDATE_DESKTOP_DATABASE);
-
-EXTRA_DIST = hexchat.appdata.xml.in hexchat.desktop.in.in htm.desktop.in htm-mime.xml
-
-CLEANFILES = $(appdata_DATA) $(data_desktop_DATA) hexchat.desktop.in