summary refs log tree commit diff stats
path: root/configure.in
diff options
context:
space:
mode:
authorBerke Viktor <bviktor@hexchat.org>2012-07-17 19:47:19 +0200
committerBerke Viktor <bviktor@hexchat.org>2012-07-17 19:47:19 +0200
commit2044a9568ccccad5e970853aca85f33be0131adc (patch)
tree57c2c341eec5463062b1ab382bb144b654258365 /configure.in
parente5f4c4d217a35f5405dc1f2a6ff9f79e2ecad705 (diff)
Add make support for Do At on Unix
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 23 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6c5e60b6..34f83f3d 100644
--- a/configure.in
+++ b/configure.in
@@ -130,9 +130,13 @@ AC_ARG_ENABLE(tcl,
         tcl=$enableval, tcl=yes)
 
 AC_ARG_ENABLE(sasl,
-[  --disable-sasl           disable the SASL plugin],
+[  --disable-sasl          disable the SASL plugin],
         sasl=$enableval, sasl=yes)
 
+AC_ARG_ENABLE(doat,
+[  --disable-doat          disable the Do At plugin],
+        doat=$enableval, doat=yes)
+
 AC_ARG_ENABLE(plugin,
 [  --disable-plugin        disable plugin support],
         plugin=$enableval, plugin=yes)
@@ -382,6 +386,21 @@ AC_MSG_CHECKING(for plugin interface used by SASL)
 fi
 
 dnl *********************************************************************
+dnl ** DO AT ************************************************************
+dnl *********************************************************************
+
+if test "$doat" != "no"; then
+AC_MSG_CHECKING(for plugin interface used by Do At)
+	doat=no
+	if test "$plugin" = yes; then
+		doat=yes
+		AC_MSG_RESULT([yes])
+	else
+		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option for Do At])
+	fi
+fi
+
+dnl *********************************************************************
 dnl ** IPv6 *************************************************************
 dnl *********************************************************************
 
@@ -595,6 +614,7 @@ AM_CONDITIONAL(DO_PERL, test "x$perl" = "xyes")
 AM_CONDITIONAL(DO_PYTHON, test "x$python" = "xyes")
 AM_CONDITIONAL(DO_TCL, test "x$tcl" = "xyes")
 AM_CONDITIONAL(DO_SASL, test "x$sasl" = "xyes")
+AM_CONDITIONAL(DO_DOAT, test "x$doat" = "xyes")
 AM_CONDITIONAL(DO_PLUGIN, test "x$plugin" = "xyes")
 AM_CONDITIONAL(USE_DBUS, test "x$dbus" = "xyes")
 AM_CONDITIONAL(DO_GCONF, test "x$GCONFTOOL" != "xno")
@@ -858,6 +878,7 @@ plugins/python/Makefile
 plugins/perl/Makefile
 plugins/tcl/Makefile
 plugins/sasl/Makefile
+plugins/doat/Makefile
 intl/Makefile
 po/Makefile.in
 ])
@@ -880,7 +901,7 @@ echo dbus support ........ : $dbus\	msproxy ntlm \(ISA\) .... : $have_ntlm
 echo libnotify support ... : $libnotify
 echo
 echo Perl ................ : $perl\	SASL .................. : $sasl
-echo Python .............. : $python
+echo Python .............. : $python\	Do At ................. : $doat
 echo Tcl ................. : $tcl
 echo
 echo The binary will be installed in $prefix/bin