summary refs log tree commit diff stats
path: root/configure.in
diff options
context:
space:
mode:
authorBerke Viktor <bviktor@hexchat.org>2012-07-18 21:19:11 +0200
committerBerke Viktor <bviktor@hexchat.org>2012-07-18 21:19:11 +0200
commita251934b36d399f9c717166fdf0be89ffda810ec (patch)
tree53c1c4c71df5c3e0a6da5b61a88c4ce9e932c80a /configure.in
parentcb2f9f3e7bb3124a95a723f1a7678c28e2bb0644 (diff)
Fix dbus-libproxy confusion causing compilation to fail with dbus disabled and libproxy present
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c8b21be6..3b6b448a 100644
--- a/configure.in
+++ b/configure.in
@@ -465,6 +465,8 @@ PKG_CHECK_MODULES([LIBPROXY], [libproxy-1.0], [libproxy=yes], [
 	libproxy=no
 ])
 if test "x$libproxy" = "xyes" ; then
+	COMMON_LIBS="$COMMON_LIBS $LIBPROXY_LIBS"
+	COMMON_CFLAGS="$COMMON_CFLAGS $LIBPROXY_CFLAGS"
 	AC_DEFINE(USE_LIBPROXY)
 fi
 
@@ -585,7 +587,7 @@ if test "x$dbus" = "xyes" ; then
 	if test "x$DBUS_BINDING_TOOL" = "xno" || test "x$GLIB_GENMARSHAL" = "xno" || test "x$dbus" = "xno" ; then
 		dbus="no"
 	else
-		COMMON_LIBS="$COMMON_LIBS $DBUS_LIBS $LIBPROXY_LIBS"
+		COMMON_LIBS="$COMMON_LIBS $DBUS_LIBS"
 		COMMON_CFLAGS="$COMMON_CFLAGS $DBUS_CFLAGS"
 		AC_DEFINE(USE_DBUS)
 		AS_AC_EXPAND(DATADIR, $datadir)