summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2014-12-02 01:06:25 -0500
committerTingPing <tingping@tingping.se>2014-12-02 01:06:25 -0500
commite38f00775f31102a696418b59e88b1586706a359 (patch)
tree5332f76a6da8ea436131bd65d8b849b18ed053b7 /configure.ac
parent05a6097dc659e6567e2d081061a44a585ddc5f67 (diff)
configure: Add option to run clang static analysis
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2177e747..eeb22b53 100644
--- a/configure.ac
+++ b/configure.ac
@@ -159,6 +159,10 @@ AC_ARG_ENABLE(minimal-flags,
 	[AS_HELP_STRING([--enable-minimal-flags],[only add those CFLAGS that are really needed or not intrusive (default: no)])],
         minimalflags=$enableval, minimalflags=no)
 
+AC_ARG_ENABLE(static-analysis,
+	[AS_HELP_STRING([--enable-static-analysis],[if using clang run static analysis during build (default: no)])],
+        analyze=$enableval, analyze=no)
+
 AC_ARG_WITH(theme-manager,
 	[AS_HELP_STRING([--with-theme-manager],[compile theme manager (needs monodevelop, default: off)])],
 		theme_manager=$withval, theme_manager=no)
@@ -588,6 +592,17 @@ if test "x$isocodes" = "xyes" ; then
 fi
 
 dnl *********************************************************************
+dnl ** Static Analysis **************************************************
+dnl *********************************************************************
+
+if test "x$analyze" = "xyes"; then
+	if test "$CC" != "clang"; then
+		AC_MSG_WARN(CC is not clang for static analysis)
+		analyze=no
+	fi
+fi
+
+dnl *********************************************************************
 dnl ** CONDITIONALS *****************************************************
 dnl *********************************************************************
 
@@ -604,6 +619,7 @@ AM_CONDITIONAL(DO_CHECKSUM, test "x$checksum" = "xyes")
 AM_CONDITIONAL(DO_DOAT, test "x$doat" = "xyes")
 AM_CONDITIONAL(DO_FISHLIM, test "x$fishlim" = "xyes")
 AM_CONDITIONAL(DO_SYSINFO, test "x$sysinfo" = "xyes")
+AM_CONDITIONAL(DO_STATIC_ANALYSIS, test "x$analyze" = "xyes")
 AM_CONDITIONAL(USE_DBUS, test "x$dbus" = "xyes")
 AM_CONDITIONAL(HAVE_ISO_CODES, test "x$isocodes" = "xyes")
 AM_CONDITIONAL(WITH_TM, test "x$theme_manager" != "xno")