summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Griffis <tingping@tingping.se>2016-03-06 18:54:07 -0500
committerPatrick Griffis <tingping@tingping.se>2016-03-06 18:54:07 -0500
commit98b0186feb75112307b0f020d604651dc006dbbc (patch)
treeb43b0cff0f5b36478f0a9854e4fe37e415c3b4e4 /configure.ac
parent35254fa6eb09ff929b742ab11e72036b0c5b99aa (diff)
build: Don't store autoconf-archive macros in repo
The release tarballs will still have them
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 08fda30d..db874e6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,11 @@ AC_CONFIG_MACRO_DIR([m4])
 AM_INIT_AUTOMAKE([1.11.1 dist-xz no-dist-gzip subdir-objects no-define foreign])
 AM_SILENT_RULES([yes])
 
+AC_DEFUN([HEX_CHECK_MACRO], [m4_ifndef([$1], [m4_fatal([macro ]$1[ is not defined. Is ]$2[ installed?])])])
+
+HEX_CHECK_MACRO([AX_IS_RELEASE], [autoconf-archive])
+HEX_CHECK_MACRO([PKG_PROG_PKG_CONFIG], [pkg-config])
+
 AX_IS_RELEASE([minor-version])
 AX_CHECK_ENABLE_DEBUG([yes])
 AX_REQUIRE_DEFINED([PKG_PROG_PKG_CONFIG])
@@ -576,7 +581,7 @@ dnl *********************************************************************
 dnl ** CFLAGS ***********************************************************
 dnl *********************************************************************
 
-CC_CHECK_FLAGS_APPEND([CFLAGS], [CFLAGS], [ \
+AX_APPEND_COMPILE_FLAGS([\
 	-pipe \
 	-funsigned-char \
 	-fstack-protector-strong \