summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Hitt <rbh00@localhost.localdomain>2013-06-15 17:26:13 -0700
committerRichard Hitt <rbh00@localhost.localdomain>2013-06-15 17:26:13 -0700
commit6a7557da0156b235b8bad58b255e16625a8ed47e (patch)
treec75ffec369055f3037abdc32af8f79083e546624 /configure.ac
parentd7045e2b6121f7750565f7b9e906bd74fecb72d9 (diff)
parente68635b8e4b0aee7d958c482abbadfc4321cf2b0 (diff)
Merge branch 'master' of http://github.com/hexchat/hexchat
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1beea6dd..4ccd1245 100644
--- a/configure.ac
+++ b/configure.ac
@@ -189,9 +189,10 @@ if test "$glib" = no; then
 	AC_MSG_ERROR(Cannot find GLib!)
 fi
 
-COMMON_CFLAGS="$GLIB_CFLAGS -DG_DISABLE_SINGLE_INCLUDES"
-COMMON_LIBS="$GLIB_LIBS"
-COMMON_LIBS="$COMMON_LIBS -lgmodule-2.0 -lgobject-2.0"
+PKG_CHECK_MODULES([GOBJECT], [gobject-2.0], [], [AC_MSG_ERROR(Cannot find gobject-2.0!)])
+
+COMMON_CFLAGS="$GLIB_CFLAGS $GOBJECT_CFLAGS -DG_DISABLE_SINGLE_INCLUDES"
+COMMON_LIBS="$GLIB_LIBS $GOBJECT_LIBS"
 
 dnl *********************************************************************
 dnl ** GTK **************************************************************