summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorTingPing <tngpng@gmail.com>2013-06-15 17:26:10 -0300
committerTingPing <tngpng@gmail.com>2013-06-15 17:26:10 -0300
commite68635b8e4b0aee7d958c482abbadfc4321cf2b0 (patch)
tree6bf5b805a6b2c41ea40b93b758267b64b66a0277 /configure.ac
parent7ef8d0d4438c8780dfe6db53add4bdc23118732a (diff)
Add configure patch from gentoo
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1beea6dd..4ccd1245 100644
--- a/configure.ac
+++ b/configure.ac
@@ -189,9 +189,10 @@ if test "$glib" = no; then
 	AC_MSG_ERROR(Cannot find GLib!)
 fi
 
-COMMON_CFLAGS="$GLIB_CFLAGS -DG_DISABLE_SINGLE_INCLUDES"
-COMMON_LIBS="$GLIB_LIBS"
-COMMON_LIBS="$COMMON_LIBS -lgmodule-2.0 -lgobject-2.0"
+PKG_CHECK_MODULES([GOBJECT], [gobject-2.0], [], [AC_MSG_ERROR(Cannot find gobject-2.0!)])
+
+COMMON_CFLAGS="$GLIB_CFLAGS $GOBJECT_CFLAGS -DG_DISABLE_SINGLE_INCLUDES"
+COMMON_LIBS="$GLIB_LIBS $GOBJECT_LIBS"
 
 dnl *********************************************************************
 dnl ** GTK **************************************************************