summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2015-02-04 21:38:45 -0500
committerTingPing <tingping@tingping.se>2015-02-04 21:41:10 -0500
commit75c022c49f96e9a1a8d61c847174cd6819cbc046 (patch)
tree73011ce41b92d8d743b810eaf7f7dea448a746b4 /configure.ac
parentf4f27e438b0791e1c0708c4f031aa80c59d965b1 (diff)
Implement OSX notification backend
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d93b2e04..99bbd3ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -206,6 +206,8 @@ dnl *********************************************************************
 
 _gdk_tgt=`$PKG_CONFIG --variable=target gdk-2.0`
 if test "x$_gdk_tgt" = xquartz; then
+		AC_PROG_OBJC
+
 		PKG_CHECK_MODULES(GTK_MAC, gtk-mac-integration-gtk2, [
 			GUI_LIBS="$GUI_LIBS $GTK_MAC_LIBS"
 			GUI_CFLAGS="$GUI_CFLAGS $GTK_MAC_CFLAGS"
@@ -597,6 +599,7 @@ AM_CONDITIONAL(DO_SYSINFO, test "x$sysinfo" = "xyes")
 AM_CONDITIONAL(DO_STATIC_ANALYSIS, test "x$analyze" = "xyes")
 AM_CONDITIONAL(USE_DBUS, test "x$dbus" = "xyes")
 AM_CONDITIONAL(HAVE_ISO_CODES, test "x$isocodes" = "xyes")
+AM_CONDITIONAL(HAVE_GTK_MAC, test "x$_gdk_tgt" = xquartz)
 AM_CONDITIONAL(WITH_TM, test "x$theme_manager" != "xno")
 
 dnl *********************************************************************