summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2013-09-26 03:06:01 -0400
committerTingPing <tingping@tingping.se>2013-09-26 03:06:01 -0400
commit6f013e807c0e4f93f360dd9d589554ee280ea5fd (patch)
tree07fde2123a855e7c251e572562b8c86f9851b9df /configure.ac
parentd18a95fda6449fc9bc3c64b7b7f0582d2b767957 (diff)
Remove whats left of gconf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 0 insertions, 36 deletions
diff --git a/configure.ac b/configure.ac
index 8f3923bd..b1cfea50 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,7 +41,6 @@ AH_VERBATIM([HEXCHATSHAREDIR],[#undef HEXCHATSHAREDIR])
 AH_VERBATIM([SOCKS],[#undef SOCKS])
 AH_VERBATIM([USE_MSPROXY],[#undef USE_MSPROXY])
 AH_VERBATIM([USE_LIBPROXY],[#undef USE_LIBPROXY])
-dnl AH_VERBATIM([USE_GNOME],[#undef USE_GNOME])
 AH_VERBATIM([USE_SHM],[#undef USE_SHM])
 AH_VERBATIM([USE_GTKSPELL],[#undef USE_GTKSPELL])
 AH_VERBATIM([USE_LIBSEXY],[#undef USE_LIBSEXY])
@@ -108,10 +107,6 @@ AC_ARG_ENABLE(textfe,
 	[AS_HELP_STRING([--enable-textfe],[build the text frontend (default: no)])],
         textfe=$enableval, textfe=no)
 
-dnl AC_ARG_ENABLE(gnome,
-dnl 	[AS_HELP_STRING([--disable-gnome],[disable use of gnome])],
-dnl        gnome=$enableval, gnome=yes)
-
 AC_ARG_ENABLE(xlib,
 	[AS_HELP_STRING([--disable-xlib],[disable use of xlib (for non X11 systems)])],
         xlib=$enableval, xlib=yes)
@@ -232,39 +227,9 @@ if test "$gtkfe" = yes ; then
 	fi
 fi
 
-if test "$gtkfe" != yes; then
-	gnome=no
-fi
-
-dnl *********************************************************************
-dnl ** GNOME ************************************************************
-dnl *********************************************************************
-
 GUI_LIBS="$GUI_LIBS $GTK_LIBS"
 GUI_CFLAGS="$GUI_CFLAGS $GTK_CFLAGS -DG_DISABLE_SINGLE_INCLUDES -DGDK_PIXBUF_DISABLE_SINGLE_INCLUDES -DGTK_DISABLE_SINGLE_INCLUDES"
 
-#if test "$gnome" = yes; then
-#	AC_MSG_CHECKING(Gnome2 compile flags)
-#	GNOME_CFLAGS="`$PKG_CONFIG libgnome-2.0 --cflags 2>/dev/null`"
-#	if test "_$GNOME_CFLAGS" = _ ; then
-#		gnome=no
-#		AC_MSG_RESULT([Gnome not found, building without it.])
-#	else
-#		GNOME_VER="`$PKG_CONFIG libgnome-2.0 --modversion`"
-#		GUI_LIBS="$GUI_LIBS `$PKG_CONFIG libgnome-2.0 --libs`"
-#		GUI_CFLAGS="$GUI_CFLAGS $GNOME_CFLAGS"
-#		AC_DEFINE(USE_GNOME)
-#		AC_MSG_RESULT(ok)
-#	fi
-#fi
-
-# GConf
-#if test "$gnome" != no ; then
-#	AC_PATH_PROG(GCONFTOOL, gconftool-2, no)
-#else
-#	GCONFTOOL=no
-#fi
-
 dnl *********************************************************************
 dnl ** XFT **************************************************************
 dnl *********************************************************************
@@ -683,7 +648,6 @@ AM_CONDITIONAL(DO_DOAT, test "x$doat" = "xyes")
 AM_CONDITIONAL(DO_FISHLIM, test "x$fishlim" = "xyes")
 AM_CONDITIONAL(DO_SYSINFO, test "x$sysinfo" = "xyes")
 AM_CONDITIONAL(USE_DBUS, test "x$dbus" = "xyes")
-#AM_CONDITIONAL(DO_GCONF, test "x$GCONFTOOL" != "xno")
 AM_CONDITIONAL(WITH_TM, test "x$theme_manager" != "xno")
 
 dnl *********************************************************************