summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorBerke Viktor <bviktor@hexchat.org>2013-04-02 22:35:42 -0700
committerBerke Viktor <bviktor@hexchat.org>2013-04-02 22:35:42 -0700
commit14b089ef90552109e3c138f48c6bdbcb4bb50766 (patch)
tree93387379102ff627edb7f2322f41fe740ba7ae4d /configure.ac
parent9c49254abd59b8e3f4ecf2be7477dd62bf399296 (diff)
Set up CFLAGS on Unix too
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a4b9f459..8aeacff2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -191,7 +191,7 @@ if test "$glib" = no; then
 	AC_MSG_ERROR(Cannot find GLib!)
 fi
 
-COMMON_CFLAGS="$GLIB_CFLAGS"
+COMMON_CFLAGS="$GLIB_CFLAGS -DG_DISABLE_SINGLE_INCLUDES"
 COMMON_LIBS="$GLIB_LIBS"
 COMMON_LIBS="$COMMON_LIBS -lgmodule-2.0 -lgobject-2.0"
 
@@ -222,7 +222,7 @@ dnl ** GNOME ************************************************************
 dnl *********************************************************************
 
 GUI_LIBS="$GUI_LIBS $GTK_LIBS"
-GUI_CFLAGS="$GUI_CFLAGS $GTK_CFLAGS"
+GUI_CFLAGS="$GUI_CFLAGS $GTK_CFLAGS -DG_DISABLE_CAST_CHECKS -DG_DISABLE_SINGLE_INCLUDES -DGDK_PIXBUF_DISABLE_SINGLE_INCLUDES -DGTK_DISABLE_SINGLE_INCLUDES"
 
 #if test "$gnome" = yes; then
 #	AC_PATH_PROG(pkgconfigpath, pkg-config)