summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2014-01-16 00:32:52 -0500
committerTingPing <tingping@tingping.se>2014-01-16 00:32:52 -0500
commiteb90f076bbdde4ca9d01ea159df22743901df2a9 (patch)
treee4e04e25c2aff0fb7fa7faaa1f45d85a94b249ea /configure.ac
parentc2c705a945bd0e695133f96fd00df028e7325db0 (diff)
configiure: Fix testing compiler flags on anything other than gcc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 1f65ae86..0ff129b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -661,13 +661,13 @@ if test "x$GCC" = "xyes"; then
 fi
 
 dnl does this compiler support -Wno-pointer-sign ?
-AC_MSG_CHECKING([if gcc accepts -Wno-pointer-sign ])
+AC_MSG_CHECKING([if $CC accepts -Wno-pointer-sign ])
 
 safe_CFLAGS=$CFLAGS
 CFLAGS="-Wno-pointer-sign"
 
 AC_TRY_COMPILE(, [
-int main () { return 0 ; }
+return 0;
 ],
 [
 no_pointer_sign=yes
@@ -683,13 +683,13 @@ if test x$no_pointer_sign = xyes; then
 fi
 
 dnl does this compiler support -funsigned-char ?
-AC_MSG_CHECKING([if gcc accepts -funsigned-char ])
+AC_MSG_CHECKING([if $CC accepts -funsigned-char ])
 
 safe_CFLAGS=$CFLAGS
 CFLAGS="-funsigned-char"
 
 AC_TRY_COMPILE(, [
-int main () { return 0 ; }
+return 0;
 ],
 [
 unsigned_char=yes
@@ -705,13 +705,13 @@ if test x$unsigned_char = xyes; then
 fi
 
 dnl does this compiler support -Wno-unused-result ?
-AC_MSG_CHECKING([if gcc accepts -Wno-unused-result ])
+AC_MSG_CHECKING([if $CC accepts -Wno-unused-result ])
 
 safe_CFLAGS=$CFLAGS
 CFLAGS="-Wno-unused-result"
 
 AC_TRY_COMPILE(, [
-int main () { return 0 ; }
+return 0;
 ],
 [
 no_unused_result=yes