summary refs log tree commit diff stats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSoniEx2 <endermoneymod@gmail.com>2022-09-03 21:23:44 -0300
committerSoniEx2 <endermoneymod@gmail.com>2022-09-03 21:25:55 -0300
commit19340aea20881674d8d87d63101da19983c64479 (patch)
tree827a8e173237e39a504a7f68b23c6d577c8483e5 /Cargo.toml
[Project] Serde Transmute
Transmute objects through Serde! This crate allows converting a
value which can be serialized into a type which can be deserialized.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..9fc580e
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "serde_transmute"
+version = "0.1.0"
+edition = "2021"
+description = "Transmute objects through serde."
+license = "MIT OR Apache-2.0"
+repository = "https://soniex2.autistic.space/git-repos/serde_transmute.git"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+serde = "1.0.144"
+
+[dev-dependencies]
+serde = {version = "1.0.144", features = ["derive"]}